Описание алгоритма Евклида блок схемой

Блок-схема алгоритма Евклида

Алгоритм Евклида на языке Кумир:

алг Евклид
нач
цел m,n          |Объявление переменных
ввод m,n         |ВВод переменных
нц пока m<>n |пока m<>n повторять
если m>n то   
m:=m-n
иначе              
n:=n-m
всё                  | конец логического блока
кц                    | конец цикла
вывод "НОД: ",m   | Вывод НОД
кон

 Алгоритм Евклида на языке Pascal

program Evklid;
var
m, n: integer;//Объявление переменных begin
readln(m, n); //ВВод переменных
while m <> n do //пока m<>n повторять
begin//Начало подпрограммы
if m > n then // если m>n то
m := m - n
else// иначе
n := n - m
end;// конец под программы
write('НОД: ', m)// вывод m
end.

  Алгоритм Евклида на языке Python 3

m=int(input("Введите первое число: "))  #Вводим первое число
n=int(input("Введите второе число: ")) #Вводим второе число'
while m!=n: # пока m<>n выполняем
if m>n: # если m>n то
m=m-n # вычитаем из большего меньшее
else: # иначе
n=n-m
print("НОД: ",m)#Выводим наибольший делитель