Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


69.9%Russian Federation Russian Federation
14.4%Ukraine Ukraine
3.2%United States United States
2.9%Romania Romania
1.2%Belarus Belarus
1.2%Czech Republic Czech Republic
1.1%United Kingdom United Kingdom
0.7%Kazakhstan Kazakhstan
0.4%Kuwait Kuwait
0.4%Azerbaijan Azerbaijan

Сегодня: 7
Вчера: 59
На этой неделе: 7
На прошлой неделе: 855
В этом месяце: 862
В прошлом месяце: 3376
Всего: 10380


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

You have no rights to post comments

   
© 2012 fordus.