Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


49.6%Russian Federation Russian Federation
19.4%Ukraine Ukraine
17.7%United States United States
1.9%Kuwait Kuwait
1.6%Kazakhstan Kazakhstan
1.5%Belarus Belarus
1.5%Romania Romania
1.4%France France
1.3%Czech Republic Czech Republic
0.7%Republic Of Moldova Republic Of Moldova

Сегодня: 97
Вчера: 236
На этой неделе: 1096
На прошлой неделе: 1421
В этом месяце: 4244
В прошлом месяце: 4850
Всего: 16962


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

Добавить комментарий


Защитный код
Обновить

   
© 2012 fordus.