Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


52.1%Russian Federation Russian Federation
21.1%Ukraine Ukraine
16%United States United States
1.9%Belarus Belarus
1.2%Romania Romania
1.1%United Kingdom United Kingdom
0.9%Czech Republic Czech Republic
0.9%Kazakhstan Kazakhstan
0.6%Kuwait Kuwait
0.6%Republic Of Moldova Republic Of Moldova

Сегодня: 8
Вчера: 311
На этой неделе: 619
На прошлой неделе: 1872
В этом месяце: 3246
В прошлом месяце: 8478
Всего: 25455


   

Учитель информатики Бамбуркин С.П.

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

Добавить комментарий


Защитный код
Обновить

   
© 2012 fordus.