Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


38.6%Russian Federation Russian Federation
30.2%Ukraine Ukraine
16.1%United States United States
2.5%Belarus Belarus
2%Czech Republic Czech Republic
1.6%Kuwait Kuwait
1.5%Kazakhstan Kazakhstan
1.2%France France
1%Romania Romania
0.5%Germany Germany

Сегодня: 46
Вчера: 67
На этой неделе: 362
На прошлой неделе: 449
В этом месяце: 1066
В прошлом месяце: 2491
Всего: 7806


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

Добавить комментарий


Защитный код
Обновить

   
© 2012 fordus.