Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


45.1%Russian Federation Russian Federation
32.1%United States United States
9.3%Ukraine Ukraine
2.2%Romania Romania
1.4%China China
1.1%Kazakhstan Kazakhstan
1%Canada Canada
1%United Kingdom United Kingdom
0.9%Australia Australia
0.5%Belarus Belarus

Сегодня: 13
Вчера: 111
На этой неделе: 124
На прошлой неделе: 684
В этом месяце: 1542
В прошлом месяце: 1644
Всего: 4828


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

You have no rights to post comments

   
© 2012 fordus.