Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


49.9%Russian Federation Russian Federation
24.5%Ukraine Ukraine
14.6%United States United States
1.9%Belarus Belarus
1.1%Romania Romania
0.8%Kazakhstan Kazakhstan
0.8%Czech Republic Czech Republic
0.7%United Kingdom United Kingdom
0.6%Republic Of Moldova Republic Of Moldova
0.6%Kuwait Kuwait

Сегодня: 46
Вчера: 315
На этой неделе: 1912
На прошлой неделе: 2232
В этом месяце: 6384
В прошлом месяце: 6131
Всего: 19365


   

Учитель информатики Бамбуркин С.П.

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Массивы в программе Кумир. Находим четные числа

Добавлено : Дата: в разделе: Прикладная информатика

В среде Кумир массив объявляют как "целтаб а[1..5]" ( квадратных скобках колличество элементов, которые допускается вводить, а целтаб означает что наши числа будут целые.)

алг
нач
целтаб а[1:5], цел з, x, y //объявляем массив и переменные
нц для з от 1 до 5 // цикл для ввода элементов массива
ввод а[з] //ввод массива
кц // конец цикла
x:=0 //обнуляем х
y:=0 //обнуляем х
нц для з от 1 до 5 // цикл для поиска четных чисел
если (mod(а[з],2)=0) то //ищем четные числа ( если число делится на 2 и в остатке 0)
x:=x+а[з] // Сумма четных чисел
y:=y+1 // колличество четных элементов в массиве
все
кц
вывод "X =",x
вывод "Y =",y
кон

 

Редактировалось Дата:

Добавить комментарий


Защитный код
Обновить

   
© 2012 fordus.