Главное меню  

   

Авторизация  

   
   
Хостинг в Украине
   


61.3%Russian Federation Russian Federation
18.6%Ukraine Ukraine
3.2%Kazakhstan Kazakhstan
2.9%Romania Romania
2.7%United States United States
1.7%Belarus Belarus
1%Republic Of Moldova Republic Of Moldova
0.9%Czech Republic Czech Republic
0.9%United Kingdom United Kingdom
0.7%Germany Germany

Сегодня: 157
Вчера: 146
На этой неделе: 424
На прошлой неделе: 960
В этом месяце: 2656
В прошлом месяце: 2198
Всего: 7368


   

блог админа

Записи

  • Главная
    Главная Страница отображения всех блогов сайта
  • Категории
    Категории Страница отображения списка категорий системы блогов сайта.

Урок №37 Логические функции и абсолютные адреса

Добавлено : Дата: в разделе: 9 класс

Основные темы параграфа:

♦ запись и выполнение логических функций; 
♦ абсолютные адреса; 
♦ функция времени.

Запись и выполнение логических функций

Продолжим совершенствование таблицы учета продажи молочных продуктов. В условии подвоза товара желательно учесть следующее обстоятельство: подвозить товар не имеет смысла, если торговый павильон заканчивает работу. Это тоже можно предусмотреть в электронной таблице. Ячейку Е9 будем использовать для хранения времени (в часах), оставшегося до конца рабочего дня. Условие подвоза товара сформулируем так: товар подвозить, если оставшееся его количество равно нулю. И до конца рабочего дня осталось больше двух часов.

При записи сформулированного выше условия в форме логического выражения должна быть использована логическая операция И (конъюнкция, логическое умножение). Работая сбазами данных, вы познакомились с логическими операциями. Однако в электронных таблицах несколько иные правила записи логических выражений, содержащих логические операции.

В электронных таблицах логические операции (И, ИЛИ, НЕ) рассматриваются как логические функции.

Например, логическое выражение, которое примет значение ИСТИНА, если выполнится сформулированное выше условие подвоза товара, пишется следующим образом (для второй строки, т. е, для йогурта):

И(Е2=0; Е9>2)

Перед скобками ставится имя логической операции (функции), а в скобках — логические операнды.

Следовательно, теперь условная функция в ячейке G2 должна выглядеть так:

ЕСЛИ(И(Е2=0; Е9>2); "Да"; "Нет")

Но в этой формуле таится опасность. Вам уже известно, что при любых манипуляциях с таблицей, связанных с переносом формул в другие ячейки, происходит изменение адресов переменных. Работает принцип относительной адресации. Однако в данном случае адрес ячейки Е9 не должен изменяться в формуле. Иначе говоря, этот адрес должен быть не относительным, а абсолютным.

Абсолютные адреса

В электронных таблицах существует способ «замораживания» адресов. На «замороженный» в формуле адрес ячейки не распространяется принцип относительности. Обычно для этой цели используется значок «$». Можно «заморозить» только номер строки или только имя столбца. Чтобы сделать абсолютным (неизменным при любом переносе формулы в таблице) адрес ячейки, нужно знак писать дважды: $Е$9.

Теперь должно быть понятно, что условную функцию, решающую вопрос о подвозе товара, следует записать так:

ЕСЛИ И(Е2=0;$Е$9>2); "Да"; "Нет" )

Функция времени

Осталось обсудить формулу, вычисляющую количество времени, оставшееся до конца рабочего дня. Можно, посмотрев на часы, вручную вставить это время в ячейку Е9. Но в современных табличных процессорах существуют специальные функции (функции времени), позволяющие получить текущее время. Это возможно благодаря тому, что в состав аппаратной части компьютеров входит таймер — внутренние часы компьютера. Если рабочий день заканчивается в 20 часов, то формула должна быть такой: 20 - ТЕКУЩИЙ ЧАС. Пусть, например, функция определения текущего часа записывается так: ЧАС(ТДАТА()).

После внесения изменений таблица в режиме отображения формул примет вид табл. 4.11, а в режиме отображения значений — табл. 4.12.

Таблица 4.11. Таблица в режиме отображения формул

A B C D E F G
 1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
Йогурт 5,4 250 225 =С2-D2 =В2*D2 =ЕСЛИ(И(Е2=0;$E$9>2);"да";"нет")
Творог 18,5 125 110 =С3-D3 =В3*D3 =ЕСЛИ(И(Е3=0;$E$9>2);"да";"нет")
Молоко 20,0 100 100 =С4-D4 =В4*D4 =ЕСЛИ(И(Е4=0;$E$9>2);"да";"нет")
Сметана 10,2 85 70 =С5-D5 =В5*D5 =ЕСЛИ(И(Е5=0;$E$9>2);"да";"нет")
Сливки 15,2 50 45 =С6-D6 =В6*D6 =ЕСЛИ(И(Е6=0;$E$9>2);"да";"нет")
ВСЕГО: =CУММ(F2:F6)
Осталось до конца дня: 20-ЧАС(ТДАТА()) часа


Таблица 4.12. Таблица в режиме отображения значений

A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 25 1215 Нет
3 Творог 18,5 125 110 15 2035 Нет
4 Молоко 20,0 100 100 0 2000 Нет
5 Сметана 10,2 85 70 15 714 Нет
6 Сливки 15,2 50 45 5 684 Нет
7 ВСЕГО: 6648
8
9 Осталось до конца дня: 2 часа

Обратите внимание на то, что из табл. 4.12 следует, что молоко уже закончилось, но подвозить его не следует, так как до конца рабочего дня осталось 2 часа.

Коротко о главном

При записи логических выражений можно пользоваться логическими операциями: И, ИЛИ, НЕ. В электронных таблицах логические операции употребляются как функции.

Возможно «замораживание» адресов ячеек, используемых в формулах. «Замороженный» адрес становится абсолютным, т. е. на него не распространяется принцип относительной адресации.

Вопросы и задания

1. Как в электронной таблице реализуются логические операции при записи условных функций?
2. Что такое абсолютный адрес?
3. В таблице «Оплата электроэнергии» (задание 6 из § 19) используйте абсолютный адрес для ячейки, хранящей стоимость 1 кВт · ч электроэнергии.
4. В таблице «Оплата электроэнергии» используйте следующее правило для подсчета суммы оплаты: если израсходовано не более 100 кВт · ч, то цена 1 кВт · ч равна 50 коп.; если израсходовано более 100, но менее 300 кВт · ч, то цена — 60 коп.; если израсходовано не менее 300 кВт · ч, то цена 1 кВт · ч равна 75 коп. Используйте логические функции.

Домашнее задание №16

Редактировалось Дата:

You have no rights to post comments

   
© 2012 fordus.